Sign in to follow this  
Followers 0
DivenParker

My ESC's keep beeping after connecting battery

3 posts in this topic

Hello all,

I've just finished my Quad F450 build and as I tried to power it on for the first time my ESC's keep beeping and the FCU doesn't power on. It this happening cause of a faulty/wrong connection I did or do I have an issue with something from my components? My build consists of :
1. Frame F450
2. Flight Controller Unit KK2.1.5
3. Motors x4
4. ESC's x4
5. UBEC
6. Battery
7. Tx/Rx

Thanks in advance for any help and info you can provide.

28732-90501981d040f8252ce38b497008ab85.jpg

28733-506ccb18a765b736ee4b54cc0b075b72.jpg

Share this post


Link to post
Share on other sites

@DivenParker if the ESCs are not getting any signal from the flight controller they typically will complain by beeping. I see that you have a UBEC so I assume that the ESCs don't have one built in. The UBEC is takes the higher unregulated voltage from the battery to provide a stable 5v to the flight controller so I would check that this is working. Also the receiver also gets its power from this UBEC but maybe via the flight controller - can you tell if it has power ?. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0



  • Welcome to UCCF.

    The UAV Coach Community Forum is actively moderated by the UAV Coach team and offered to help serve those in the UAV industry. Use this space to meet and greet, to ask and answer questions, to share what you're working on, etc. Have fun, play nice, and fly safe! :)

  • Forum Statistics

    • Total Topics
      1,831
    • Total Posts
      9,158