Michael Lucas

Members
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Michael Lucas

  • Rank
    Newbie
  1. All, I recently acquired a 4 year old PrecisionHawk Lancaster UAV that has never been flown (long story) and I am trying to upgrade it to the latest firmware (3.15). It currently has version 3.2 installed and to be able to upgrade it to 3.15, I have to have a minimum of 3.4 installed. I've reached out to PrecisionHawk and asked for 3.4. They pointed me to version 3.15. Does anyone have or know where I can get a copy of version 3.4? Best, msl