Search the Community

Showing results for tags 'phantom 2 vision +'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • PRIMARY FORUM CATEGORIES
    • Drone Pilot Talk
    • News & Events
    • Regulations Discussion
    • Business Advice
    • Aerial Photography
    • The Pilot Lounge
    • Community Updates
    • Where to Fly a Drone
  • CLASSIFIED
    • For Sale
  • POSTS BY INDUSTRY / USE CASE
    • 3D / GIS / Land Surveying / Mapping
    • Filmmaking / Cinematography
    • Property / Real Estate Marketing
    • Public Safety / Emergency Services
    • Agriculture
    • Construction
    • Inspections
    • FPV / Drone Racing
    • Other
  • POSTS BY DRONE MODEL
    • DJI Mavic Series
    • DJI Phantom Series
    • DJI Inspire Series
    • DJI Matrice Series
    • DJI Spark
    • Yuneec
    • Parrot
    • Accessories & Other Drone Models
    • DIY

Product Groups

There are no results to display.

Blogs

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me

Found 1 result

  1. I had sent in my drone to DJI to repair a motor. At the time my unit was covered under the warranty. I had some issues with the timeliness of the repair, but I wasn't too concerned as I borrowed my dad's UAS in the meantime (and he has no desire to have it back). So once I had received my original UAS back, it remained in the box for a while. Well I recently took it out and noticed some differences. I assumed it was due to the repairs that were completed and didn't think anything much. But today I was updating my flight log and decided to check the S/N and to my surprise I didn't receive my UAS back. I have sent DJI and email and am awaiting their response. I keep records of my flights and maintenance, and now I have a unit that may have had a previous life. I guess I am looking for any advice or ideas on how to handle this issue. Or would like to know if others have had similar issues. Thanks!