Recommended Posts

I am currently trying to change the flight mode while flying my copter but cannot do it properly. Using mission planner's actions tab I can change the flight mode while the copter is disarmed on the ground without issue. Once I arm the drone it no longer responds to mode changes. This appears to be true for any mode change including RTL and AUTO. The flight computer is the pixhawk with standard firmware loaded onto it.

 

I am using a 3dr DIY quad copter kit and a frsy receiver bound to an iris+ controller. I am unsure where the problem lies and am starting to think it may have to do with the configuration on my handheld controller. If anybody has any insight or recommendations as to where to look please let me know and thanks in advance!

  • Like 2
Link to post
Share on other sites

I have an APM board on my UAV which as you may know is the predecessor to the Pixhawk and runs the same software. I've setup a 3 position switch on my Tarranis XD9 transmitter for the 3 flight modes: stabilize,  loiter and RTL which allows me to change flight modes in the air. I also have 915 mhz telemetry connecting my laptop running mission planner to the APM flight controller but I have not tried to change flight modes using the action tab but its something that I could try. 

 

  • Like 3
Link to post
Share on other sites

If you could try using MP next time you get a chance that would be great. For my purposes I need it to happen automatically through a script. I figured the issue was with my script but when I checked directly through MP it was unable to change as well. Curious if it's a firmware issue or something else that I'm just unaware of.

  • Like 1
Link to post
Share on other sites

I performed a quick bench test and found that I could change the flight mode to RTL using the MP action tab. With the props removed I armed the quad and increased the throttle to simulate it was in the air. I then clicked on the "Do Action" to initiate the RTL. I answered yes to "Are you sure want to RETURN_TO_LAUNCH" and the status in the artificial horizon changed from "stabilize" to "RTL". Also the motor RPMs increased and I had no longer control on my transmitter so it must be working. The version of ArduCopter is 3.2.1 and the mission planner version is 1.3.34.

  • Like 2
Link to post
Share on other sites

Thank your for testing that out for me. I have tested again and still have the same issue. I know it is supposed to behave the way yours does. I'm going to look into the versions of my firmware/software and see if there are any new updates that may fix it. Unfortunately that doesn't shed much light on whats wrong with mine but I very much appreciate your help.

  • Like 1
Link to post
Share on other sites
  • 3 weeks later...

So I believe I have solved the issue. In case anybody else is having this or a similar issue. The ground station was having difficulty receiving parameters as well as issuing commands because the telemetry stream was too fast. The drone wasn't getting a chance to read the port to see if the ground stations was issuing commands. Simply turning down the MP attitude rate solved my problem.

  • Like 1
Link to post
Share on other sites
  • 3 years later...

hello ;
 

On 2/10/2016 at 6:27 PM, tsinatra said:

So I believe I have solved the issue. In case anybody else is having this or a similar issue. The ground station was having difficulty receiving parameters as well as issuing commands because the telemetry stream was too fast. The drone wasn't getting a chance to read the port to see if the ground stations was issuing commands. Simply turning down the MP attitude rate solved my problem.

Hello how did you change MP attitude rate?
where can I find it ?

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.