Mavic Firmware

Recommended Posts

 I fly P3P, Inspire and just got a Mavic Pro. When I loaded DJI firmware a new one loaded called "Drone Volt Pilot".  It contains firmware for all three of my drones.  I  spent all day Sat trying to get it to work. Is this a problem with me or the new firmware.  The old firmware just worked without registration that wants passwords, emails etc.  I have tried to key in what it wants with no luck.  You have really helped me in the past; any suggestions?

Share this post

Link to post
Share on other sites

Can you post a screen shot of what you are seeing , are you saying new app or firmware as the Mavic and the P3 use different apps andncompletly different firmware methods of  updating. 

The Mavic Pro, P4 series and Inspire 2 should be using DJI Go 4 

the Inspire 1 and P3 would use DJI Go. 


If you can post a screen shot we can go from there 

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Welcome to UCCF.

    The UAV Coach Community Forum is actively moderated by the UAV Coach team and offered to help serve those in the UAV industry. Use this space to meet and greet, to ask and answer questions, to share what you're working on, etc. Have fun, play nice, and fly safe! :)

  • Forum Statistics

    • Total Topics
    • Total Posts