problems with DJI P4P "aircraft Disconnected"


MartyL
 Share

Recommended Posts

Hi all,

just got my P4P back from DJI after issues with Vision System calibration warnings needed attention.   After 2 weeks in the shop, I took my P4P to the construction site I am monitoring and now have "aircraft disconnected".   Never had this problem, 16-18 satellites available typically at this site, where I have been monitoring construction for past 87 months.  I have tried various things: turned off and on, disconnected cables, changed location on site, no interference problems that I can see.  I checked the DJI site, they recommend disconnecting cable on the RC.  Did that.  no luck.  Has anyone encountered this?  I plan to contact DJI on Monday, since they don't work weekends.  :((

Link to comment
Share on other sites

On 6/16/2018 at 2:35 PM, MartyL said:

Hi all,

just got my P4P back from DJI after issues with Vision System calibration warnings needed attention.   After 2 weeks in the shop, I took my P4P to the construction site I am monitoring and now have "aircraft disconnected".   Never had this problem, 16-18 satellites available typically at this site, where I have been monitoring construction for past 87 months.  I have tried various things: turned off and on, disconnected cables, changed location on site, no interference problems that I can see.  I checked the DJI site, they recommend disconnecting cable on the RC.  Did that.  no luck.  Has anyone encountered this?  I plan to contact DJI on Monday, since they don't work weekends.  :((

I get the same problem out of the Inspire occasionally. My workaround is to shut everything down including iPad. Start the RC first. Start the aircraft and wait until it is fully turned on. Then start the iPad and load the GO app. It might take a few times of repeating the process. Hope this helps.

Link to comment
Share on other sites

  • 2 years later...

Hi, am late to the party but just thought I'd reply as I faced the same problem after flying my P4 for 5 years without any problems. I had a sensor error come up and sent mine in for repairs. When it returned I just couldn't connect. Later the repair store tells me that I needed to reconnect/relink my RC controller with my drone as during repair they had used their own RC to do tests. As I found out, to achieve relinking one would have to go through the normal process of initialization, choosing RC settings in the app and clicking on the RC linking option. The red light next to the SD card slot should light up. Use a mobile phone pin to press that red light for a few seconds. The light should start blinking. When the RC and Drone gets linked the RC should beep and you should get a picture on your screen. That's it guys. Hope that helps. 

*Your problem could be something else too. This is just one probable solution. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share