Is LAANC authorization via Airmap down for you, too?

Recommended Posts

I fly in PHX's class B about every week. Friday I tried, didn't get a text, and Airmap said "authorization rejected." So I tried in a couple other LAANC active airspaces that I've flown in before (Scottsdale and Denver). Same rejected msg. Same issue today.

 I've started a ticket with Airmap... can anyone test as well? Thanks.

Share this post

Link to post
Share on other sites
1 hour ago, Philip Moore said:

Hey @Kemper

A good alternative is 

Just tried Kittyhawk for the first time yesterday and it worked! Still can't get Airmap working. Stinks... 75 flights then it stopped. I'm working with their support.


Now I just need Kittyhawk to support LAANC authorizations on the Android app! Works fine on the iPad, though.

Share this post

Link to post
Share on other sites

@Alan Perlman @Kemper I did not know that Kittyhawk was not Android compatible.

The one upgrade I wish they could enhance is to track flights from flying apps outside of DJI GO. I use Airdata when I have to use dronedeploy, litchi, or autopilot, but it would be nice to have everything under one roof.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.