WalterK

Problem with Tablet not Synching w/ DJI Mavic Pro

Recommended Posts

I recently purchased a DJI Mavic Pro and want to use my Samsung Galaxy Tab A with the DJI GL200A controller.  Unfortunately I can't get the table to "connect".  I have tried several cables so it doesn't appear to be a cable problem.  I tried a Samsung Galaxy Tab S4 and it works, once I changed the "debug" setting under developer settings.  There doesn't seem to be a way for me to access a similar settiong on the Tab A.  Any thoughts or suggestions on what could be causing the Tab A not to connect?  Thanks.

Share this post


Link to post
Share on other sites
n the spirit of "self-help," I went to BestBuy and bought a new Samsung Galaxy Tab A6 (for a little over $100).  They also sell DJIs.  The sales clerk assured me that it would work and sure enough it did work (after turning on the USB debug option).  It is even an improvement in that it is 7" vs. the older tablet's 8" size, so it can fit in the controller arms, no need for a support accessory.
 
From this I can only assume that the original Android 5.0.2 operating system is not compatible with the Mavic Pro controller.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.