r9mm & Mamba F722s F.Port Problems

Recommended Posts

I am having a terrible time trying to set up F.Port on a Mamba F722s (30x30). 
FC, Reciever, and Transmitter and R9M are all up to date with latest FCC firmware.

The reciever (r9mm) is bound to my QX7 & R9M Module. I switched some of the wires around and was able to run SBUS and can confirm I get stick movement but am not seeing any stick movement when the serial reciever provider is set to Fport option.
In this case, the green wire (SBUS) is removed. The white wire (smartport wire) I've tried running F.Port from the smartport pin as well as the inverted smartport pin from the r9mm and both times no luck.
in betaflight TX2 seems to be linked to UART1, TX3 to UART2 and so on.

Attached is a picture of my wiring and I know no pads are bridged.
I've been watching tons of tutorials on setting up F.Port and I really have no idea what else to try other than soldering the smartport wire potentially to another TX pad.

Any help is much appreciated!!!



Share this post

Link to post
Share on other sites

I've been continuing my research on this and realize I was incorrect about TX2 - UART1
UART1 is reserved for SBUS, UART4 is reserved for Bluetooth, and UART6 is used for ESC telemetry.
So technically when I enable Serial RX on UART2 (TX2) I should get signal from my r9mm outputting from the Smartport pad.

I emailed Diatone about this but their only help is "look at our diagram" which I have stared at for days.
Attached is the supplied diagram for the Mamba F722s Stack


Screen Shot 2020-02-28 at 7.41.07 AM.jpg

Share this post

Link to post
Share on other sites



still trying to figure this out.

tried all TX pads to run FPort - no luck

re-updated all equipment - no luck

flashed flex fport firmware onto r9m and r9mm and checked “flexr9m” box on open TX - no luck

Have tried playing with “serialrx halfduplex” and “serialrx inverted” - no luck

I am out of ideas and ended up ordering another r9mm. Will flash with FPort Flex firmware and see if we get some stick movement.

if not, looks like I’ll just be running SBUS with smartport.


Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.