One motor doesn't rotate with all the motors but if a little throttle is given then the motor rotates


Recommended Posts

Hey guys I'm working on my quadcopter project. One of my motor doesn't start with all my motors when I trigger a pin in my transmitter but if I increase the throttle then it starts to rotate. I don't know what's the problem, I have swapped the motor, checked the ESC's, soldering has been done properly. I'm in deep trouble as my submission dates are very near. I'm using K K board 2.1.5 as my flight controller. If anybody can help me out that would be really kind of you. I don't know but I'm worried guys. I'm using CT6B 2.4GHz 6Ch transmitter and FS-R6B receiver

Link to comment
Share on other sites

A couple of things you can check.  It’s been a long time since I’ve used a KK board. 

  1. Are all the motors connected in the right order on your FC?
  2. Did you calibrate your throttle?
  3. Have you set the idle rpm (the speed the motors rotate when you’ve armed it)
  4. Is the drone set still on a level surface when you plug in the battery and arm it?

keep in in mind that if the drone is not level then the “uphill” motor doesn’t need to rotate.  Once you’ve armed the drone, pick it up and gently rotate the angle around the center of mass, does the motor that doesn’t spin up work?

Have you flown the drone?

Link to comment
Share on other sites

Thank you for replying Av8Chuck.

                 The motors are connected in the right order. The throttle is calibrated. I have calibrated a switch on my transmitter when pushed all the motors start to rotate but one of the motor is not working. I have swapped the motor and checked, I have opened the ESC but everything seems fine. I know if I'm asking for too much help but guys its my final year project. I'm running out of ideas.

This is my mail-id :

Kindly contact me guys. Would be really helpful.

Link to comment
Share on other sites

Have you tried to fly it?  

It doesn’t appear the be a motor or ESC issue (if their connected correctly). 

Unfortunatley, like I mentioned earlier I have not built a drone in quite a while (I have people for that), so I’m probably not going to be able to help.  

Have you checked  

Link to comment
Share on other sites

  • 1 month later...
2 hours ago, Rahul said:

Can someone help??

Have you calibrated the ESCs ?. If not you do this by connecting a ESC directly to the receiver's throttle channel. Do one ESC at a time without the the flight controller involved.

First make sure that the props have been removed. 

  • Turn on the transmitter and move the throttle to full.
  • Connect the battery so the ESC and RX are powered on.
  • You should hear some beeps and then move the throttle to minimum. You may hear some more beeps.
  • Disconnect the battery.
  • Reconnect the battery and check that when you move the throttle up the motor RPMS increase.

The above procedure sets the min and max range for a ESC.

If you already did the above and its still not working then

what happens when you change that motor with one that's working ?. Does the problem move or stay with the ESC ?

what happens when you connect that ESC to another port on the flight controller ?. Again does the issue move or stay with the FC's port ?

If the issue follows the same ESC its possible that the configuration has changed or was not set like the others - what make and model of ESC are you using and what firmware is loaded ?. 





Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.