ESC Configuration issue with BLHeli32


Recommended Posts

Hi all!

I am a beginner, building his first quadcopter and I am seeking for help to resolve an issue that I am really struggling to resolve. The drone is assembled, but when I try to read and flash the ECS set up using BLHeli 32, no ECS is found and the following window appears:

BLHeli32_suite_noValidESC_merged.thumb.PNG.55f58278debba8797e64d9b48d1ba789.PNG

Before that, I have selected the Interface “M BLHeli32 Bootloader (Betaflight/Cleanflight)”, connected it to the FC with success and added the power supply (battery) with the corresponding ECS bipping. Here more details:

ECS: Chaos 30A BLHeli_32 ESC 

FC: Kakute F7 AIO (v1.5 / MPU6000)

BLHeli_32 Suite version: 32719

I have tried it also via BLHeli Configurator version: win64_1.2.0 and Android app “BLHeli 32” but the result is the same one.

Before using BLHeli, I have configured the quadcopter using Betaflight (10.7.0), binded the RX and TX. I don’t know if it is part of the same problem,  in Betaflight when I give throttle using the controller, none of the motors spin, but the signals are received. Here few screenshots:

ECS_Config.PNG.ccb241dec2dbb8dd07fbe3ee3dccf316.PNG

Motors_with_throttle.thumb.PNG.e441f9f493ff7b48fb67565aa8d7a8c6.PNG

Thank you in advance for any indication and I stay available to provided further information.

have a nice evening,

Fabrizio.

Link to post
Share on other sites
  • 2 weeks later...
  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.