APM 2.8 Bad Compass Health and RC not Calibrated


Nikcopter
 Share

Recommended Posts

Hello,
I am new to drones and need some assistance, I have an APM 2.8 flight controller while calibrating it in Mission Planner it gives an error as bad compass health and it does not show the points for calibration in live calibration mode. So, I bought a new flight controller of the same specifications it shows the same error and while calibrating RC it does not respond to the transmitter but keeps flickering on its own. I tried even installing firmware again but of no use, the transmitter is bound to the receiver.

During compass calibration, I don’t get the points to calibrate the drone,

image

And during radio calibration, without me using the transmitter the green lines keep flickering,

image
The transmitter-receiver I am using is from flysky FS-I6b, and the copter is f450 with 1400kv Bldc motors and 10" props, and no GPS.
Thanks in advance, kindly help me with this issue.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share